Question Form not properly updating

thohm

New member
Joined
Aug 2, 2013
Messages
3
Programming Experience
10+
Hi there,


I'm having a PowerPoint add-in (not really worth mentioning details here) and one button is openening a Windows Forms form. Now I've had to change the fields of said form and something is going crazy from here.


I've added another text field, changed an old text field to be single line instead of multi, moved a DateTimePIcker field to a new position and added some new labels to the form. The new text field and the label are shown on form. But everything that was on the form before still has old forms and positions (i.e. my old text field is still multiline). So my form doesn't seem to update the old (changed) controls.


Is .NET or Office caching Windows Forms somewhere, because it looks exactly like this. Or am I missing something?
As I'm in the middle of a work that needs to get finished today I would really appreciate if anyone could help me out here, even if you're not sure your possible solution could help.


Regards,
Thomas
 

thohm

New member
Joined
Aug 2, 2013
Messages
3
Programming Experience
10+
Another thing: I've installed my addin on a different machine to check if some kind of caching is the problem. And even on a different machine it the same problem, so it seems the issue is during compilation of the form.
 

thohm

New member
Joined
Aug 2, 2013
Messages
3
Programming Experience
10+
I'm answering myself now:)

I didn't really find a solution, but a workaround:

I've had to copy the existing controls, name them to a different name and deleted the old ones. That way at least I got my controls to where I wanted them to be.

If anyone had a similar situation and knows the real cause, please update this thread nevertheless, because this problem might come up another time for me or a different forum reader.

Regards,
Thomas
 
Top Bottom