Resolved Productivity Power Tools 2017/2019 extension stops copy operation in Visual Studio 2017.

priyamtheone

Member
Joined
Sep 18, 2011
Messages
11
Programming Experience
Beginner
I'm using Visual Studio 2017. After installing Productivity Power Tools 2017/2019 extension, I can't use the copy operation. The first time I try to copy a line or block of code after installing the extension, Visual Studio generates an error saying:

"Type library exporter encountered an error while processing 'CopyAsHtml.CopyAsHtmlPackage, CopyAsHtml'. Error: Type library exporter encountered an error while processing 'Microsoft.VisualStudio.Shell.Interop.SVsSolutionObject, Microsoft.VisualStudio.Shell.Interop'. Error: Type 'SVsSolutionObject' and type 'SVsSolution' both have the sameUUID."

Next time onwards, whenever I try to copy, Visual Studio generates the error saying:

"Unspecified error (Exception from HRESULT: 0x80004005 (E_FAIL))"

When I uninstall Productivity Power Tools 2017/2019, there's no error message and I can copy everything properly. It seems, the problem is with the extension. So, is there a way to fix the problem so that I can use Productivity Power Tools 2017/2019 and not encounter the problem at the same time? Or shall I have to give up using Productivity Power Tools 2017/2019 entirely and continue Visual Studio without it?

Regards
 
Solution
Delving deep into the issue brings across the fact that a sub-component of the Productivity Power Tool extension, named Copy As Html, is breaking the copy/cut operation. Disabling/uninstalling the sub-component solves the problem as per my observation. Though, I'm not sure what other essential operation is deactivated by the disabling of the sub-component.

Got to Tools > Extensions and Update and select the Installed node on the left panel. In the list of extensions in the middle, scroll down to Copy As Html and disable or uninstall it.

Skydiver

Staff member
Joined
Apr 6, 2019
Messages
5,251
Location
Chesapeake, VA
Programming Experience
10+
You probably would have a better answer by asking that makers of that extension.
 

priyamtheone

Member
Joined
Sep 18, 2011
Messages
11
Programming Experience
Beginner
Delving deep into the issue brings across the fact that a sub-component of the Productivity Power Tool extension, named Copy As Html, is breaking the copy/cut operation. Disabling/uninstalling the sub-component solves the problem as per my observation. Though, I'm not sure what other essential operation is deactivated by the disabling of the sub-component.

Got to Tools > Extensions and Update and select the Installed node on the left panel. In the list of extensions in the middle, scroll down to Copy As Html and disable or uninstall it.
 
Solution
Top Bottom