Resolved sap crystal report with c-sharp is not showing result in client pc

madhugp

Member
Joined
Nov 27, 2017
Messages
20
Programming Experience
5-10
Hi,
I am using c# windows application in visual studio 2012 on windows 10 64-bit.
I installed sap crystal reports 64-bit (Its name is CRforVS13SP26_0-10010309) .
Sap crystal report in c# has been developed and running fine and showing the
report result in my system. I used oledb connection with sql server 2014
when developing report. But the executable file of c# application is not working
on client pc which has windows 10 and sql server 2014. . At client pc also I installed
the same sap crystal reports. Sap crytal reports and it 64 bit run time has been installed.
But At client pc the if I run exe file it hangs by showing document is under processing
and shows an error message " connection failed".
plz check the attachment.

thanks and regards
madhu
 

Attachments

  • screen_error.jpg
    screen_error.jpg
    879.3 KB · Views: 5

Skydiver

Staff member
Joined
Apr 6, 2019
Messages
4,029
Location
Chesapeake, VA
Programming Experience
10+
I suspect that Crystal Reports is running into the same SQL connection problems as in your other thread. Did you resolve the problem in your other thread? If so, what was the resolution and did you apply the same fix for your Crystal Reports configuration?
 

madhugp

Member
Joined
Nov 27, 2017
Messages
20
Programming Experience
5-10
I suspect that Crystal Reports is running into the same SQL connection problems as in your other thread. Did you resolve the problem in your other thread? If so, what was the resolution and did you apply the same fix for your Crystal Reports configuration?

Yes , the other thread problems was connection to sql server has been resolved. The problem is we have to use correct server name.
usually we use the server name with "\sqlexpress " . But at client pc it has been configured without using "\sqlexpress". After I used the actual name
the problem has been resolved.
 

madhugp

Member
Joined
Nov 27, 2017
Messages
20
Programming Experience
5-10
I suspect that Crystal Reports is running into the same SQL connection problems as in your other thread. Did you resolve the problem in your other thread? If so, what was the resolution and did you apply the same fix for your Crystal Reports configuration?

But the current thread problem is still pending. Can u plz suggest any solution
 

Attachments

  • screen_error.jpg
    screen_error.jpg
    879.3 KB · Views: 1

Skydiver

Staff member
Joined
Apr 6, 2019
Messages
4,029
Location
Chesapeake, VA
Programming Experience
10+
I don't use Crystal Reports, but from those I've heard use it, my understanding is that it uses it's own configuration and you need to give it a connection string. Do the connection strings match?
 

madhugp

Member
Joined
Nov 27, 2017
Messages
20
Programming Experience
5-10
I don't use Crystal Reports, but from those I've heard use it, my understanding is that it uses it's own configuration and you need to give it a connection string. Do the connection strings match?
The problem has been resolved after using connection strings that match with own pc. I used odbc connection with windows authentication also same odbc connection name at client pc with windows authentication. Now sap crystal report is running at client pc without error. thanks for your support.
 
Top Bottom