trouble with the links

bhs67

Well-known member
Joined
Oct 11, 2021
Messages
50
Programming Experience
10+
I had trouble with the links in the first post. Remove the "." and the link is changed to the title on that website. How do I stop this from happening?
 

Skydiver

Staff member
Joined
Apr 6, 2019
Messages
4,029
Location
Chesapeake, VA
Programming Experience
10+
One way is to initially put it into your post, then edit it afterwards. You'll find URL will look something like this:
C#:
[URL unfurl="true"]https://docs.microsoft.com/en-us/dotnet/api/system.io.file.readallbytes?view=net-5.0[/URL]
change that unfurl="true" to unfurl="false"

Another way is to type in the BBCODE yourself while you are composing:
C#:
[URL unfurl="false"]https://docs.microsoft.com/en-us/dotnet/api/system.io.file.readallbytes?view=net-5.0[/URL]
 

bhs67

Well-known member
Joined
Oct 11, 2021
Messages
50
Programming Experience
10+
It would be good if this were fixed. Thanks for the prompt response.
 

Skydiver

Staff member
Joined
Apr 6, 2019
Messages
4,029
Location
Chesapeake, VA
Programming Experience
10+
I suspect that due to the popularity of Slack, Teams, Twitter, etc. and other messaging platforms, people have come to expect automatic URL unfurling. It's us old timers who want a URL to stay a URL when we type/paste it in.
 

JohnH

C# Forum Moderator
Staff member
Joined
Apr 23, 2011
Messages
1,265
Location
Norway
Programming Experience
10+
'unfurling' is normally useful just for readability, it can also useful if link some time later is changed and you still have the page title and can search that up.

(moved these posts to new thread in Forum Feedback by the way)
 
Top Bottom