How can I consume a webservice that uses WSSE?


New member
Jan 23, 2014
Programming Experience
Hey everyone. I've run into a problem that I've been trying to figure out for the last 3 days, and I'm not having any luck at all. I'm hoping someone may be able to help me out on something.

I am trying to write a C# Winform application that can access a third party's webservice that uses WSSE. I'll try to provide as many details as possible.

The header for the request needs to be like the following:

<soapenv:Envelope xmlns:efil="" xmlns:soapenv="">
      <wsse:Security xmlns:wsse="" xmlns:wsu="">
         <wsse:UsernameToken wsu:Id="UsernameToken-3">
            <wsse:Password Type="">mypassword</wsse:Password>
            <wsse:Nonce EncodingType="">Uw0swuaymypUcDTUpJ0i0Q==</wsse:Nonce>

I can use the above header (minus the Nonce) in an app called SoapUI and call a method (listStuff) that will return data. However, whenever I try to do so in code, I'm not getting any results. This is what I have tried:

1. Added a Service Reference to the webservice (
2. Added a namespace to reference this:
using Svc = testProject.ServiceReference1;
3. On a button click event, I then tried to call a method by create a client, setting the username/password, but I am not getting any results:
Svc.CreateInterfaceClient client = new Svc.CreateInterfaceClient();
client.ClientCredentials.UserName.UserName = "username";
client.ClientCredentials.UserName.Password = "password";

Svc.stuff[] myStuff = client.listStuff();

I'm not getting any exceptions being thrown, but myStuff is empty (it should contain several hundred "stuff" objects).

I haven't had to work with webservices before, and I'm sure it's something that I'm just doing wrong. I haven't had any luck finding any examples online that I can go by to figure this out.

Thanks in advance!
Top Bottom