Will .Net 4.5 framework work with C# from VS 2003? System.collections.Generic

Valhalla

Member
Joined
Jun 16, 2013
Messages
10
Programming Experience
10+
I have .net 1.1 framework and Visual Studio.net 2003. 1.1 framework does not provide the system.Collections.Generic for Lists. I'm wondering if I can upgrade to .net 4.5 framework and have it work with Visual Studio.net 2003?

Also will installing Visual Studio Express conflict with Visual Studio.net 2003 or the .net 1.1 framework?

Thanks you!

Valhalla
 

jmcilhinney

C# Forum Moderator
Staff member
Joined
Apr 23, 2011
Messages
3,142
Location
Sydney, Australia
Programming Experience
10+
I have .net 1.1 framework and Visual Studio.net 2003. 1.1 framework does not provide the system.Collections.Generic for Lists. I'm wondering if I can upgrade to .net 4.5 framework and have it work with Visual Studio.net 2003?
No you can't.

VS.NET (2002) => .NET 1.0
VS.NET 2003 => .NET 1.0 - 1.1
VS 2005 => .NET 2.0
VS 2008 => .NET 2.0 - 3.5
VS 2010 => .NET 2.0 - 4.0
VS 2012 => .NET 2.0 - 4.5
VS 2013 => .NET 2.0 - 4.5

You need at least VS 2012 to target .NET 4.5 but, in fact, if all you want is a generic List then you only need to target .NET 2.0. You should still install the latest version though, which can target as far back as .NET 2.0. Note that VS 2013 is still in beta.
Also will installing Visual Studio Express conflict with Visual Studio.net 2003 or the .net 1.1 framework?
There will be no issue at all. You can have every version of the .NET Framework, VS and VS Express all installed on the same machine at the same time and they will happily coexist. They were designed with that in mind.
 

Valhalla

Member
Joined
Jun 16, 2013
Messages
10
Programming Experience
10+
Thanks...for the great thorough answer!

No you can't.

VS.NET (2002) => .NET 1.0
VS.NET 2003 => .NET 1.0 - 1.1
VS 2005 => .NET 2.0
VS 2008 => .NET 2.0 - 3.5
VS 2010 => .NET 2.0 - 4.0
VS 2012 => .NET 2.0 - 4.5
VS 2013 => .NET 2.0 - 4.5

You need at least VS 2012 to target .NET 4.5 but, in fact, if all you want is a generic List then you only need to target .NET 2.0. You should still install the latest version though, which can target as far back as .NET 2.0. Note that VS 2013 is still in beta.There will be no issue at all. You can have every version of the .NET Framework, VS and VS Express all installed on the same machine at the same time and they will happily coexist. They were designed with that in mind.

Thanks for such a thorough answer. That's exactly what I need to know.
 
Top Bottom